SoftwareEntwicklung Beratung Schulung

A coders, hackers heaven.....Hm...I do not think so...

Apache Maven Shade Plugin Version 2.4 Released

| Comments

The Apache Maven team is pleased to announce the release of the Apache Maven Shade Plugin, version 2.4.

This plugin provides the capability to package the artifact in an uber-jar, including its dependencies and to shade – i.e. rename – the packages of some of the dependencies.

You should specify the version in your project’s plugin configuration:

1
2
3
4
5
<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-shade-plugin</artifactId>
  <version>2.4</version>
</plugin>

Release Notes – Maven Shade Plugin – Version 2.4

Bugs:

  • MSHADE-155 – dependency-reduced-pom should use shadedArtifactId
  • MSHADE-169 – Typos in warning message
  • MSHADE-172 – “java.lang.ArithmeticException: / by zero” in MinijarFilter
  • MSHADE-174 – Unable to shade Java 8 jarfiles with static interface methods using minimizeJar
  • MSHADE-183 – Getting “Error creating shaded jar: java.util.jar.Attributes cannot be cast to java.lang.String” error when using ManifestResourceTransformer with Maven 3.2.5
  • MSHADE-185 – systemPath content is interpolated for system dependencies

Improvements:

  • MSHADE-177 – MavenProject/MavenSession Injection as a paremeter instead as a component.
  • MSHADE-178 – Removing plexus-container-default dependency
  • MSHADE-179 – Fix RAT Report
  • MSHADE-180 – Upgrade plexus-utils to 3.0.18
  • MSHADE-188 – Upgrade maven-dependency-tree to 2.2
  • MSHADE-191 – Upgrade plexus-utils to 3.0.22
  • MSHADE-192 – Upgrade maven-invoker to 1.10
  • MSHADE-193 – Upgrade to fluido skin 1.4.0

Enjoy,

-The Apache Maven team

Comments