SoftwareEntwicklung Beratung Schulung

A coders, hackers heaven.....Hm...I do not think so...

Apache Maven PMD Plugin Version 3.5 Released

| Comments

The Maven team is pleased to announce the release of the Apache Maven PMD Plugin, version 3.5.

A Maven plugin for the PMD toolkit, that produces a report on both code rule violations and detected copy and paste fragments, as well as being able to fail the build based on these metrics.

You should specify the version in your project’s plugin configuration:

1
2
3
4
5
<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-pmd-plugin</artifactId>
  <version>3.5</version>
</plugin>

Release Notes – Apache Maven PMD Plugin – Version 3.5

Bugs:

  • MPMD-208 Warning about deprecated Rule name when using rulesets/maven.xml
  • MPMD-205 Javascript violations won’t fail the build

Improvements:

  • MPMD-211 Upgrade plexus-resources from 1.0-alpha-7 to 1.1
  • MPMD-209 Upgrade to PMD 5.3.2
  • MPMD-206 Make the sourceDirectories configurable

New Feature:

  • MPMD-207 Support Javascript and JSP for CPD

Enjoy,

-The Maven team

Comments