SoftwareEntwicklung Beratung Schulung

A coders, hackers heaven.....Hm...I do not think so...

Apache Maven PMD Plugin Version 3.6 Released

| Comments

The Maven team is pleased to announce the release of the Apache Maven PMD Plugin, version 3.6

A Maven plugin for the PMD toolkit, that produces a report on both code rule violations and detected copy and paste fragments, as well as being able to fail the build based on these metrics.

You should specify the version in your project’s plugin configuration:

1
2
3
4
5
<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-pmd-plugin</artifactId>
  <version>3.6</version>
</plugin>

Release Notes – Apache Maven PMD Plugin – Version 3.6

Bugs:

  • MPMD-218 – Update to PMD 5.3.5
  • MPMD-217 – False positive UselessParentheses
  • MPMD-215 – FieldDeclarationsShouldBeAtStartOfClass false positive
  • MPMD-186 – Class names with slash are omitted from exclusions on pmd:check

Enjoy,

-The Maven team

Comments