SoftwareEntwicklung Beratung Schulung

A coders, hackers heaven.....Hm...I do not think so...

Apache Maven Compiler Plugin Version 3.5 Released

| Comments

The Apache Maven team is pleased to announce the release of the Apache Maven Compiler Plugin, version 3.5.

The Compiler Plugin is used to compile the sources of your project.

Attention: Starting with this version, the maven-compiler-plugin requires Maven 3 and won’t work with Maven 2 anymore.

You should specify the version in your project’s plugin configuration:

1
2
3
4
5
<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-compiler-plugin</artifactId>
  <version>3.5</version>
</plugin>

Release Notes – Maven Compiler Plugin – Version 3.5

New Feature:

  • MCOMPILER-203 – Allow compiler-plugin to specify annotation processor dependencies

Bug:

Improvement:

Enjoy,

-The Apache Maven team

Comments