SoftwareEntwicklung Beratung Schulung

A coders, hackers heaven.....Hm...I do not think so...

Apache Maven PMD Plugin Version 3.7 Released

| Comments

The Maven team is pleased to announce the release of the Apache Maven PMD Plugin, version 3.7

A Maven plugin for the PMD toolkit, that produces a report on both code rule violations and detected copy and paste fragments, as well as being able to fail the build based on these metrics.

You should specify the version in your project’s plugin configuration:

1
2
3
4
5
<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-pmd-plugin</artifactId>
  <version>3.7</version>
</plugin>

Release Notes – Apache Maven PMD Plugin – Version 3.7

Bugs:

  • MPMD-162 – PMD/CPD report does not take into account pmd.excludeFromFailureFile
  • MPMD-178 – ExcludeRoots doesn’t handle subdirectories (PMD isn’t working nicely with Android projects)
  • MPMD-213 – Remove unnecessary (read-only) parameter “language” from check goal
  • MPMD-219 – Maven PMD Plugin ignores PMD processing errors

Improvements:

  • MPMD-212 – Add documentation and IT for MPMD-206
  • MPMD-220 – Upgrade to PMD 5.5.1 (requires Java 7)
  • MPMD-227 – Document multimodule configuration example
  • MPMD-228 – Upgrade maven-plugins to version 30
  • MPMD-229 – Cleanup POM, remove temporary workarounds

Tasks:

  • MPMD-196 – Do not rely in tests on toLowerCase but on toLowerCase(Locale.ROOT)
  • MPMD-226 – Require Java 7

Enjoy,

-The Maven team

Comments