SoftwareEntwicklung Beratung Schulung

A coders, hackers heaven.....Hm...I do not think so...

Apache Maven Invoker Plugin Version 3.1.0 Released

The Apache Maven team is pleased to announce the release of the Apache Maven Invoker Plugin, version 3.1.0.

The Invoker Plugin is used to run a set of Maven projects. The plugin can determine whether each project execution is successful, and optionally can verify the output generated from a given project execution.

This plugin is in particular handy to perform integration tests for other Maven plugins. The Invoker Plugin can be employed to run a set of test projects that have been designed to assert certain features of the plugin under test.

You should specify the version in your project’s plugin configuration:

1
2
3
4
5
<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-invoker-plugin</artifactId>
  <version>3.1.0</version>
</plugin>

You can download the appropriate sources etc. from the download page:

https://maven.apache.org/plugins/maven-invoker-plugin/download.cgi

Release Notes – Maven Invoker Plugin – Version 3.1.0

Bugs:

  • MINVOKER-191 – “Artifact is not fully assembled” error with maven-invoker-plugin in parallel/multi thread build
  • MINVOKER-224 – Unable to set cloneProjectsTo to null

New Feature:

Improvement:

Tasks:

  • MINVOKER-228 – Improve documentation: “Using with other integration test frameworks” page
  • MINVOKER-237 – Upgrade to JDK 7 minimum.

Dependency upgrades:

Enjoy,

-The Apache Maven team