SoftwareEntwicklung Beratung Schulung

A coders, hackers heaven.....Hm...I do not think so...

Apache Maven Install Plugin Version 3.0.0-M1 Released

The Apache Maven team is pleased to announce the release of the Apache Maven Install Plugin, version 3.0.0-M1.

The Install Plugin is used during the install phase to add artifact(s) to the local repository. The Install Plugin uses the information in the POM (groupId, artifactId, version) to determine the proper location for the artifact within the local repository.

Important Note since 3.0.0-M1:

  • Maven 3.X only
  • Minimum JDK 7+
  • The maven-install-plugin does not generate any kind of checksum anymore.

Usage Note:

  • Use the maven-install-plugin 3.0.0-M1 only in combination with the maven-deploy-plugin 3.0.0-M1.
1
2
3
4
5
<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-install-plugin</artifactId>
  <version>3.0.0-M1</version>
</plugin>

You can download the appropriate sources etc. from the download page.

Release Notes – Maven Install Plugin Version 3.0.0-M1

Bugs:

  • MINSTALL-121 – The packaging property should not be used for the file extension
  • MINSTALL-130 – Remove link to non-existing Codehaus wiki

Improvements:

  • MINSTALL-110 – install-file should also install bundled pom.xml from artifact.
  • MINSTALL-114 – Plugin shouldn’t depend on maven-compat dependency
  • MINSTALL-118 – MavenProject with only attachments must have packaging “pom”
  • MINSTALL-124 – Remove hard code version for maven-invoker-plugin
  • MINSTALL-128 – Replace usage of the deprecated ArtifactFactory
  • MINSTALL-134 – Remove checksum generation
  • MINSTALL-136 – Removed unused dependency
  • MINSTALL-143 – Move checksum generation from install to deploy plugin

Tasks:

Dependency upgrades:

Enjoy,

-The Apache Maven team

Karl-Heinz Marbaise