SoftwareEntwicklung Beratung Schulung

A coders, hackers heaven.....Hm...I do not think so...

Apache Maven Surefire Plugin Version 2.22.2 Released

The Apache Maven team is pleased to announce the release of the Apache Maven Surefire Plugin, version 2.22.2.

The release contains 1 bug fixes. Again we received contributions from the community in form of bug reports and bug fixes. Thank you and keep them coming!

You should specify the version in your project’s plugin configuration:

1
2
3
4
5
<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-surefire-plugin</artifactId>
  <version>2.22.2</version>
</plugin>

or for failsafe:

1
2
3
4
5
<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-failsafe-plugin</artifactId>
  <version>2.22.2</version>
</plugin>

or for surefire-report:

1
2
3
4
5
<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-surefire-report-plugin</artifactId>
  <version>2.22.2</version>
</plugin>

Release Notes – Maven Surefire – Version 2.22.2

Bugs:

  • SUREFIRE-1614– JUnit Runner that writes to System.out corrupts Surefire’s STDOUT when using JUnit’s Vintage Engine

Enjoy,

-The Apache Maven team