SoftwareEntwicklung Beratung Schulung

A coders, hackers heaven.....Hm...I do not think so...

Apache Maven PMD Plugin Version 3.13.0 Released

The Maven team is pleased to announce the release of the Apache Maven PMD Plugin, version 3.13.0

A Maven plugin for the PMD toolkit, that produces a report on both code rule violations and detected copy and paste fragments, as well as being able to fail the build based on these metrics.

You can download the appropriate sources etc. from the download page.

You should specify the version in your project’s plugin configuration:

1
2
3
4
5
<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-pmd-plugin</artifactId>
  <version>3.13.0</version>
</plugin>

Release Notes – Apache Maven PMD Plugin – Version 3.13.0

  • Bugs:

    • MPMD-288 – NullPointerException when File.list() returns null
    • MPMD-289 – check: unable to find pmd.xml
    • MPMD-292 – PMD Log is not always integrated into maven log
    • MPMD-295 – Maven PMD Plugin fails on Java 13: Unsupported targetJdk value ‘13’
  • New Feature:

    • MPMD-269 – Display PMD version that is being used
  • Improvements:

    • MPMD-241 – Document the version relationship between plugin and pmd
    • MPMD-287 – Add additional contribution information for GitHub
    • MPMD-296 – Copy ruleset files into a subdirectory of target
  • Wish:

    • MPMD-225 – Create report even if no warnings have been found by default
  • Tasks:

    • MPMD-285 – remove pluginTools version override for build (which block reproducible build…)
    • MPMD-293 – Fix integration test builds on jenkins

Dependency upgrade:

MPMD-291 – Upgrade to PMD 6.21.0

Enjoy,

-The Maven team